9602

Error:Execution failed for task ':app:processDebugAndroidTestManifest'

Question:

this is what happened when i update buildToolsVersion from 26.0.1 to 26.0.2.

<blockquote>

Error:Execution failed for task ':all:processDebugAndroidTestManifest'. Manifest merger failed : Attribute meta-data#android.support.VERSION@value value=(26.0.2) from [com.android.support:cardview-v7:26.0.2] AndroidManifest.xml:25:13-35 is also present at [com.android.support:support-v13:26.0.1] AndroidManifest.xml:28:13-35 value=(26.0.1). Suggestion: add 'tools:replace="android:value"' to element at manifestMerger8124076249449477164.xml:23:9-25:38 to override.

</blockquote>

but i didn't add support-v13:26.0.1 library to my project!!

i tried to add tools:replace="android:value" to manifest, and clean - rebuild, nothing changed.

build.gradle:

dependencies { compile 'com.android.support:appcompat-v7:26.0.+' compile 'com.android.support:design:26.0.+' compile 'com.android.support:cardview-v7:26.0.+' compile 'com.android.support:recyclerview-v7:26.0.+' compile 'cn.pedant.sweetalert:library:1.3' compile 'com.nineoldandroids:library:2.4.0' compile 'com.daimajia.easing:library:1.0.1@aar' compile 'com.daimajia.androidanimations:library:1.1.3@aar' compile 'com.google.code.gson:gson:2.8.2' compile 'com.wdullaer:materialdatetimepicker:3.3.0' }

Answer1:

The com.wdullaer:materialdatetimepicker library uses it. You can check <a href="https://github.com/wdullaer/MaterialDateTimePicker/blob/master/library/build.gradle#L28" rel="nofollow">the dependencies here.</a>

Add in your build.gradle an explicit dependency to use the same level of support libraries:

compile 'com.android.support:support-v13:26.0.2'

Answer2:

You can override this conflict between the manifests of your application's dependencies by adding tools:replace="android:value" in the meta-data tag of your <b>own</b> manifest, and specifying the value you want to use.

<meta-data android:name="android.support.VERSION" android:value="26.0.2" tools:replace="android:value" />

P.S: If you do not already have a meta-data tag, you should add it inside your application tag in your AndroidManifest.xml

Recommend

  • How to retain instance of fragment of fragment playing video after change in orientation?
  • Can I cleanse a numpy array without a loop?
  • How to write this polyvariadic composition function in Haskell?
  • BSD md5 vs GNU md5sum output format?
  • Django cascade save?
  • Removing duplicate rows by adding column value
  • Access sharepoint list from web site hosted externally from sharepoint
  • .HTML5 alternative for frames with 1 fixed (menu) column
  • How to use webview as a browser in android application?
  • Manifest marge error after migrating to androidX
  • Apprequest of Android Facebook sdk 3.0
  • OWL Api, move class from parent A to B
  • OpenCv 2.4.3: can't find imread and SurfFeatureDetector::detect
  • Giving a model knowledge of a many-to-many related model in django
  • Keyboard Extension Crash on Device
  • Project Euler -Prob. #20 (Lua)
  • Firebase suddenly reports invalid signature
  • Identifying dates in strings using NLTK
  • Hyperlink to Outlook Attachment
  • Thick underline when hover AND when active
  • Jekyll - How do I create pages in the root directory?
  • Spring annotation @Order
  • How to create OLE Automation to be used with ClearExplorer
  • Google TV VideoView playing YouTube rtsp videos
  • Create an Office365 mailbox from within C# Web API method
  • Wireshark Display Filter for Unique Source/Destination IP and Protocol
  • Silverlight Event Log in Isolated Storage
  • Creating 2d platforms using JavaScript
  • How to define something in JavaScript [closed]
  • using maven pom while creating jar:test-jar some times it says JAR will be empty - no content was ma
  • How convert html to BBcode in C#
  • How to integrate angular2-material (alpha 8.2) with angular2-Quickstart app
  • Send array to next viewcontroller iOs xcode [duplicate]
  • Comma decimal separator is ignored by ASP.NET MVC model binder
  • Cross compile glibc for arm, got undefined reference to some unwind functions
  • media foundation H264 decoder not working properly
  • Running R's aov() mixed effects model from Python using rpy2