I'm using Ubuntu 16.04 and after installing the pre-requisites, I followed the steps here:
<a href="https://hyperledger.github.io/composer/next/installing/development-tools.html" rel="nofollow">https://hyperledger.github.io/composer/next/installing/development-tools.html</a>
Everything installed without erros but when I ran this command:
I got this error:<pre class="lang-none prettyprint-override">
"Cannot use v0.18.2 version of composer with fabric 1.1, v0.19 or higher is required"
I was surprised v0.19 wasn't installed as part of that set up if it's needed.
How can I now upgrade to composer v0.19?Answer1:
Run this line:
npm install -g firstname.lastname@example.orgAnswer2:
Be sure that you the composer component of the php is not installed. you can check it by seeing its version. composer --version. if the result is something like this 1.6.0, remove that. You can find the path by "which composer" command.
Then check and update the version. You can find the latest stable version <a href="https://www.npmjs.com/package/composer-cli" rel="nofollow">here</a>. Now it is 0.19.9
npm install -g email@example.com