66538

hyperledger composer installation issue

Question:

I'm using Ubuntu 16.04 and after installing the pre-requisites, I followed the steps here:

<a href="https://hyperledger.github.io/composer/next/installing/development-tools.html" rel="nofollow">https://hyperledger.github.io/composer/next/installing/development-tools.html</a>

Everything installed without erros but when I ran this command:

./createPeerAdminCard.sh

I got this error:

<pre class="lang-none prettyprint-override">"Cannot use v0.18.2 version of composer with fabric 1.1, v0.19 or higher is required"

I was surprised v0.19 wasn't installed as part of that set up if it's needed.

How can I now upgrade to composer v0.19?

Answer1:

Run this line:

npm install -g composer-cli@0.19.0

Answer2:

Be sure that you the composer component of the php is not installed. you can check it by seeing its version. composer --version. if the result is something like this 1.6.0, remove that. You can find the path by "which composer" command.

Then check and update the version. You can find the latest stable version <a href="https://www.npmjs.com/package/composer-cli" rel="nofollow">here</a>. Now it is 0.19.9

npm install -g composer-cli@0.19.9

Recommend

  • Error Reporting in WCF Service?
  • how to catch ALL javascript errors with window.onerror? (including dojo)
  • How to quantitatively measure goodness of fit in SciPy?
  • Catching an unhandled exception prior to it reaching Application level
  • Sort Perl array in place?
  • R: Random sampling an even number of observations from a range of categories
  • can't add multicast group
  • gcc treat all warnings as errors EXCEPT X
  • No System image available when adding AVD in Android studio
  • How is user.dir configured for Tomcat servlets?
  • Errno 2 using python shutil.py No such file or directory for file destination
  • How to import Navit into Eclipse and use it in own android project
  • Splash Screen will not display
  • Building Qt project for C++11 standard
  • Android Database Error - getWriteableDatabase
  • Xamarin Android | Layout style
  • configure: error: no acceptable C compiler found in $PATH
  • Python pickle not one-to-one: different pickles give same object
  • Cannot upload to OneDrive using the new SDK
  • How do I configure context broker accept post requests from my remote sensor?
  • Sonar maven jacoco code coverage for Multimodule project
  • zope_i18n_compile_mo_files doesn't work on a Zeo configuration
  • How do I exclude a dependency in provided scope when running in Maven test scope?
  • Make VS2015 use angular-cli ng at build time in a .NET project
  • Setting up SourceTree to merge unity3d scenes with UnityYAMLMerge
  • The plugin 'org.apache.maven.plugins:maven-jboss-as-plugin' does not exist or no valid ver
  • When to use `image` and when to use `Matrix` in Emgu CV?
  • Jenkins: How To Build multiple projects from a TFS repository?
  • Uncaught Error: Could not find module `ember-load-initializers`
  • How do I fake an specific browser client when using Java's Net library?
  • SSO with signing and signature validation doesn't work
  • Deserializing XML into class C#
  • Can I make an Android app that runs a web view in Chrome 39?
  • Updated Ionic CLI but shows previous version (Windows)
  • Apache 2.4 - remove | delete | uninstall
  • Run Powershell script from inside other Powershell script with dynamic redirection to file
  • Use group_by to filter specific cases while keeping NAs
  • How to include full .NET prerequisite for Wix Burn installer
  • costura.fody for a dll that references another dll
  • jQuery Masonry / Isotope and fluid images: Momentary overlap on window resize