Docusign error TAB_REFERS_TO_MISSING_DOCUMENT

This should be pretty simple. I have one composite template with 1 server template and 1 inline template with one signer. This is what the request looks like:

{ "compositeTemplates": [ { "serverTemplates": [ { "sequence": "1", "templateId": "c6dc72a6-51ae-47c3-a55a-7923a247f97c " } ], "inlineTemplates": [ { "sequence": "2", "recipients": { "signers": [ { "name": "Kathy Keaton", "email": "KathyKeaton1@outlook.com", "recipientId": "1", "routingOrder": "1", "roleName": "##Buyer1" } ] } } ], "document": { "documentId": "1", "name": "Doc1ForBigTest.docx", "fileExtension": "docx", "documentBase64": [bytearray] } } ], "status": "sent", "emailSubject": "Please sign the following document at 10:21 AM" }

I want to use my copy of this particular document instead of the one in the template, but I get the TAB error mentioned above. What am I doing wrong? Thanks for any help.

Answer1:

You will need to download your template and look at the documentId references. It is likely that at some point the Web interface was used to update the document in the template, causing the new document to be added and the old one deleted. This involved updating the tab documentId references to be updated to "2" or higher. Now, when you substitute your document, you are specifying documentId="1" and DocuSign doesn't find a document with ID of "2" to put the tabs on.

人吐槽 人点赞

Recommend

Comment

用户名: 密码:
验证码: 匿名发表

你可以使用这些语言

查看评论:Docusign error TAB_REFERS_TO_MISSING_DOCUMENT