55493

Wamp server error. could not execute run action

I am trying to start wamp serve which was totally running fine on my laptop two weeks ago, but now after two weeks I suddenly get this error:

could not execute menu item(internal error)[exception] could not execute run action: the directory name is invalid

When I click on wamp, then I go to apache, then I select service then test port 80 and this is what I see:

<img src="https://i.stack.imgur.com/frmix.jpg" alt="enter image description here">

when I write localhost, it goes there but when I click on Localhost and phpMyAdmin, i get this error: <img src="https://i.stack.imgur.com/m8wly.jpg" alt="enter image description here">

please tel me how I can fix this . thanks

Answer1:

WAMP is trying to open your browser, but the directory in the settings is not correct. It could be that your browser is now located somewhere else. To fix this:

<ol> <li>Edit the file wampmanager.conf inside your wamp direcotry.</li> <li>Replace the full file path under the [main] section for the navigator parameter</li> <li>Save the file</li> <li>Right-click on the wamp icon and select refresh</li> <li>Try it now</li> </ol>

Good luck!

Answer2:

I had a similar problem, and to get my WAMP server working again on my laptop I ran the executables for Apache and MySql independant of the WAMP system tray icon.

In Windows Explorer, I ran (elevated):

{wamp folder in my case C:\wamp}bin\apache\apache2.2.22\bin\ApacheManager.exe

This put the apache manager system tray icon in. then I used the apache system tray icon to start apache server Then I ran (elevated): {C:\wamp}bin\mysql\mysql5.5.24\bin\mysqld.exe

This allowed me to use localhost\phpmyadmin, which to me demonstrates the php, mysql and apache are all working.

My web app was also back and running.

The age of my MySql version and apache version show how long this had been stable for.

I initially thought the problem may have been caused by a google chrome upgrade which included the notifications icon in the system tray, as the chrome upgrade was the only thing I recall changing. I unistalled chrome but this did not fix it - although this does not rule out Chrom Notifications being what broke it!

Answer3:

The paths are incorrect in multiple ini files and the wampmanager conf file. Here are the ones I changed since my installed moved from g drive to e drive. I had to change all instances of g:/ to e:/ as well as my chrome.exe location

wampmanager.conf: in the [main] section update the path of chrome.exe or ensure it is correct.

wampmanager.ini: change all instances of g:/ to e:/ (or whatever your install drive letter is)

php.ini (under /wamp/bin/php/php5.5.12/) again, change all instances of g:/ to e:/ (change to your install letter)

Wampmanager started correctly once these changes were made.

Answer4:

i have met this problem and fixed by editing 4 files - wampmanager.conf in root - wampmanager.ini in root - php.ini in (wamp64/bin/php/php5.5.12) - httpd.conf in (wamp64\bin\apache\apache2.4.18\conf)

Recommend

  • Can't install PostgreSQL: An error occurred executing the Microsoft VC++ runtime installer on W
  • How to use a controller in an other file in Angularjs
  • Visual Studio: Garbled debug watch of std::string's?
  • Building project succeed with Access database, can search the data but cannot delete the record
  • WCF error “The X.509 certificate chain building failed” despite trusted root CA
  • How To Protect Database Files From Copying In Windows
  • How to store pointer to S3 objects in Amazon SimpleDB?
  • Is it really posible to close a PhoneGap App?
  • How do I customize header and footer in jqgrid?
  • How to load a CascadeClassifier using Emgu c#
  • Find first match in table range
  • Ignore some files from SVN commit
  • What is the best way to include a style sheet for a specific page?
  • How to modify the HTML tag in Drupal 6?
  • Undefined navigator.push React-native 0.43.4
  • Aptana 3 remove bundle (jquery)
  • How do I retrieve the user information of a user authenticated with Apache's mod_ldap?
  • Servlet stops working on Tomcat server after some hits or time
  • Best way to dynamically load an xml configuration file into a Flex4/Flash movie at runtime?
  • Uncaught TypeError: $(…).select2 is not a function
  • Web.config system.webserver errors
  • print() is showing quotation marks in results
  • Make VS2015 use angular-cli ng at build time in a .NET project
  • Android fill_parent issue
  • javaw.exe and eclipse startup problems
  • Get object from AWS S3 as a stream
  • output of program is not same as passed argument
  • script to move all files from one location to another location
  • SSO with signing and signature validation doesn't work
  • ILMerge & Keep Assembly Name
  • Symfony2: How to get request parameter
  • Properly structure and highlight a GtkPopoverMenu using PyGObject
  • Akka Routing: Reply's send to router ends up as dead letters
  • R: gsub and capture
  • AT Commands to Send SMS not working in Windows 8.1
  • Run Powershell script from inside other Powershell script with dynamic redirection to file
  • C# - Getting references of reference
  • Android Google Maps API OnLocationChanged only called once
  • unknown Exception android
  • Checking variable from a different class in C#