83417

Clean install VestaCP

i have private server i using SSH for access my server i have remove VestaCP (i using http://vestacp.com/docs/#how-to-uninstall-vesta method) i using UBUNTU 16.04 LTS

I try to clean up <strong>vestaCP</strong> with this method:

apt-get remove --purge nginx apache2 apache2-utils apache2.2-common apache2-suexec-custom libapache2-mod-ruid2 libapache2-mod-rpaf libapache2-mod-fcgid bind9 idn mysql-server mysql-common mysql-client php5-common php5-cgi php5-mysql php5-curl libapache2-mod-php5 vsftpd mc exim4 exim4-daemon-heavy clamav-daemon flex dovecot-imapd dovecot-pop3d phpMyAdmin awstats webalizer jwhois rssh git spamassassin roundcube roundcube-mysql roundcube-plugins sudo bc ftp lsof ntpdate rrdtool dnsutils vesta vesta-nginx vesta-php

Then i try to install the VestaCP as usual:

curl -O http://vestacp.com/pub/vst-install.sh; bash vst-install.sh --nginx yes --apache yes --phpfpm no --named yes --remi yes --vsftpd yes --proftpd no --iptables yes --fail2ban yes --quota no --exim yes --dovecot yes --spamassassin yes --clamav yes --mysql yes --postgresql yes

But I have error at <strong>mysql-server-5.7</strong> as:

mysql_upgrade failed with exit status 11 dpkg: error processing package mysql-server-5.7

How to fix that?

Answer1:

The following is generic advice from VestaCP in their documentation:

// Perhaps try stopping mysql-server, apache2, and nginx as well, just incase they're holding up the uninstall. Also, can you post the output/errors if any?

<ol> <li>

Stop vesta service service vesta stop

</li> <li>

Remove vesta packages and software repository <strong>RHEL/CentOS:</strong> yum remove vesta* rm -f /etc/yum.repos.d/vesta.repo Debian/Ubuntu: apt-get remove vesta* rm -f /etc/apt/sources.list.d/vesta.list

</li> <li>

Delete data directory and cron rm -rf /usr/local/vesta

</li> </ol>

Honestly, if you're at a point where you can purge all these files, it's probably easier to reinstall your operating system. Failing that, get another VPS(Virtual Private Server) on the go.Install Vesta on the new server, apply any backups of your website(s) and database(s), and then install/setup any services (other than Vesta) you had running on the current server.

If that is completely out of the question, you can find out exactly which packages it installs depending on which version and linux distribution you use. For example the click here for the Ubuntu version.

Just underneath if [ "$release" = '16.04' ]; then is the block of software that the script apt-get installs.

Answer2:

Try using --force with your install command or reinstall ubuntu

Recommend

  • Clean install VestaCP
  • java is not working in linux. Why?
  • Git push to GitHub failing - seems to be trying to use HTTP?
  • Accessing twitter using tornado.httpclient using proxy [closed]
  • YouCompleteMe unavailable : requires Vim 7.4.143
  • Bash Shell: for loop returns different values
  • Node/less: util.puts: Use console.log instead
  • How to reinstall Ruby and Gem on Mac OS X
  • How to run shell commands with root privileges in Java
  • Error response from daemon: network myapp not found
  • Thrift Client can't connect
  • Unable to import python-mysqldb
  • Angular: Binding to a observable property of service -> value doesn't update
  • R grep regular expression using elements in a vector
  • RXTX gnu.io.PortInUseException: & WARNING: RXTX Version mismatch
  • “ModuleNotFoundError: No module named ” in my Docker container
  • Checking if URL exists - HTTP Request always returns an exception
  • PDF file damaged after upload but local copy is fine. How could this be happening? [closed]
  • How to install dependencies while creating a .deb installer?
  • Is there a list of URL schemes?
  • Permission Denied when executing python file in linux
  • Getting States and Provinces in .NET
  • Is need install mysql on AWS EC2 if i am using AWS rds as database instance?
  • Maintaining a reliable session in express
  • How to implement HTTPS in laravel 5.4
  • mysql auto kill query
  • Error while installing ggplot in python
  • How do I run my Specs with the previous version of Rspec?
  • missing pie chart and other elements when display serenity report from jenkins
  • Using docker environment -e variable in supervisor
  • Does SmartGit support git-svn?
  • FTPWebRequest .NET 3.5 vs 4
  • MAVEN : Run Multiple Maven Project using Maven Test
  • TFS - how do I sum child task hours to parent
  • jquery validation - waiting for remote check to complete
  • Is it possible to run clang with llc flags
  • How to handle elastic beanstalk deployment so it uploads only changed files
  • How to install node-mysql?
  • jQuery tmpl and DataLink beta
  • Google cloud sdk not working when python points python3